Mikrotik, povezivanje na captive portal s loginom

poruka: 15
|
čitano: 1.787
|
moderatori: Lazarus Long, pirat, XXX-Man, DrNasty, vincimus
1
+/- sve poruke
ravni prikaz
starije poruke gore
3 mjeseca
offline
Mikrotik, povezivanje na captive portal s loginom

Kako da konfiguriram mikrotik  :

 

Hoću se spojiti na udaljeni hotspot s captive portalom i loginom. U svrhu spajanja na Internet moje Wlan mreže.

 

Probao sam spojiti wlan1 interface na hotspot i bridgat na ether1, ali niš od toga. Wlan1 interface sam stavio na station pseudobridge mode. 

 

Schema:

 

[HOTSPOT] ---wireless--- [MikroTik SXTsq Lite2 ] ---kabel--- [drugi wifi router] 

 

 

Hvala. 

Poruka je uređivana zadnji put pon 2.8.2021 11:25 (Theophilus Ruy).
 
0 0 hvala 0
8 godina
offline
Mikrotik, povezivanje na captive portal s loginom

Trebalo bi raditi. Ja bih izvadio wlan1 iz bridge, budući da ionako wlan1 (klijent prema hotspotu) i tvoj ostatak LAN-a doma neće biti isti subnet. Eventualno upaliti dhcp klijent na wlan1. 
Dići masquerade na Lan-u za sve što ide preko wlan1 van. 

Kupujem HUAWEI stickove za mobilni internet, ponude na PM ;)
Poruka je uređivana zadnji put pon 2.8.2021 11:25 (srcipesak).
 
0 0 hvala 0
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
srcipesak kaže...

Trebalo bi raditi. Ja bih izvadio wlan1 iz bridge, budući da ionako wlan1 (klijent prema hotspotu) i tvoj ostatak LAN-a doma neće biti isti subnet. Eventualno upaliti dhcp klijent na wlan1. 
Dići masquerade na Lan-u za sve što ide preko wlan1 van. 

  Povezao sam wlan1 s hotspotom i dhcp client na wlan1 interfaceu je dobio IP adresu od hotspota.

 

Ali nemogu pingat ništa s tog interfacea.

 

 

 želim samo da mikrotik proslijedi sve s ether1 na wlan1 i obrnuto. 

Poruka je uređivana zadnji put pon 2.8.2021 11:40 (Theophilus Ruy).
8 godina
offline
Re: Mikrotik, povezivanje na captive portal s logi

Imas masquerade dignut? 

 

https://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT -> source nat pogledaj, ovaj prvi primjer. Znači tebi bude OUT wlan1, i onda "skrivaš" svoj LAN iza adrese wlan1. 

Kupujem HUAWEI stickove za mobilni internet, ponude na PM ;)
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
Ne razumijem.

Kako ću povezati "LAN wifi router" na mikrotikov wlan1? , Wlan1 je već povezan na hotspot

A "lan wifi router" ću povezati na mikrotikov ether1 kabelom.

Poruka je uređivana zadnji put pon 2.8.2021 11:57 (Theophilus Ruy).
8 godina
offline
Re: Mikrotik, povezivanje na captive portal s logi

Gore iz dijagrama ja shvatio da je sxt wifi klijent na hotspot, a da lan s SXT ide prema drugom ruteru. SXT mora raditi NAT u tom slucaju. 

Kupujem HUAWEI stickove za mobilni internet, ponude na PM ;)
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
...



Poruka je uređivana zadnji put uto 3.8.2021 20:52 (Theophilus Ruy).
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
...
Poruka je uređivana zadnji put sri 4.8.2021 0:05 (Theophilus Ruy).
 
0 0 hvala 0
10 godina
offline
Mikrotik, povezivanje na captive portal s loginom

Ako je captive portal moraš prvo otvoriti browser da te redirektira na portal da se prijaviš.(kad je sve skoženo)

 

Isto ako ne želiš bridge već svoj IP range, moraš dodjeliti IP adresu na ether1 interface, i to neku koja je iz drugog ip range od ovog od hotspot.

 

Pa zatim još i dodat ip pool i upaliti DHCP seerver na ether1

Poruka je uređivana zadnji put sri 4.8.2021 11:53 (ivicask).
 
0 0 hvala 0
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
Složio sve kao Router u Quick set.

I ne šljaka.

Onda sam složio kao bridge u quick set

Tada je proradilo nakon što sam stavio gateway da bude ip od hotspot, na lokalnoj mašini.

Ali sporo to radi brate (neupotrebljivo) . Hotspot je udaljen negdje 50m, u međuvremenu je i drveće na LOSu dobilo lišće.

Signal strength - 80 do - 90 decibela

Možda bude bolje po zimi.
Poruka je uređivana zadnji put sri 4.8.2021 12:02 (Theophilus Ruy).
10 godina
offline
Re: Mikrotik, povezivanje na captive portal s logi
Theophilus Ruy kaže...
Složio sve kao Router u Quick set.

I ne šljaka.

Onda sam složio kao bridge u quick set

Tada je proradilo nakon što sam stavio gateway u hotspot na lokalnoj mašini.

Ali sporo to radi brate (neupotrebljivo) . Hotspot je udaljen negdje 50m, u međuvremenu je i drveće na LOSu dobilo lišće.

Signal strength - 80 do - 90 decibela

Možda bude bolje po zimi.

 

Da nešto ti je falilo, optrilike ovo ti je potrebno da bi radilo kako si htio prvo ako nisam nešto fulo ovo se može copy paste u terminal,al pazi može biti konfliakta ako već imaš neke rulove i može te default firewall rules zezat, neznam kolko se snalaziš sa mikrotik.

 

/ip address
add address=192.168.88.1/24 comment=defconf interface=ether1 network=\
192.168.88.0


/ip pool1
add name=pool1 ranges=192.168.88.2-192.168.88.254

 

/ip dhcp-server
add address-pool=pool1 interface=ether1 name=defconf

 

/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 gateway=\
192.168.88.1

/ip dns
set allow-remote-requests=yes cache-size=2048KiB max-concurrent-queries=20 \
max-concurrent-tcp-sessions=50 servers=1.1.1.1,8.8.8.8.8

/ip firewall nat
add action=masquerade chain=srcnat out-interface=wlan1

 

Što se tiče signala ima mali trik...

 

U postavkama wlan1 pod Wireless stavi pod Frequency Mode sa regulatory na superchannel, ako ti javi da nije podržana država tipa Croatia probaj bosnu ili no_country_set mislim da tamo ne zeza, to će ti ugl otključat full snagu vidi kakav je onda signal.

Poruka je uređivana zadnji put sri 4.8.2021 12:08 (ivicask).
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi
Hvala, probati ću.

EDIT:
Diglo je tx power na 30 dbm-a, (sa 10 dbm koji je po regulaciji)
Ali speed test i dalje loš.

Poruka je uređivana zadnji put sri 4.8.2021 13:56 (Theophilus Ruy).
10 godina
offline
Re: Mikrotik, povezivanje na captive portal s logi
Theophilus Ruy kaže...
Hvala, probati ću.

EDIT:
Diglo je tx power na 30 dbm-a, (sa 10 dbm koji je po regulaciji)
Ali speed test i dalje loš.

 Stavi Band na N only umjesto tipa b,g,n i pod advanced imaš adaptive noise immunty staviti "ap and client mode"

 

Al ugl, možda je hotspot zagušen ili namjerno limitiran po korisniku, ili imaju neku bolju oprema koja ima rogue client station detection tako nešto zabravio sam kako se zove, baš namjenjeno da blokira/usporava to što ti želiš napraviti :D.

Mislim* da pomaže u tom slučaju da koristiš Station Mode a ne pseudobridge jel kontroler ga vidi kao jedan klijent, a trenutno si u bridge pa vidi i sve tvoje uređaje po mreži i kuži da nije jedan uređaj spojen na hotspot.Al onda moraš raditi NAT ove gore komande što sam ti dao.

 

I daj screen status page gdje se vidi konekcija, snaga, CCQ, SNR itd..zanima me kako izgleda

Poruka je uređivana zadnji put sri 4.8.2021 14:15 (ivicask).
8 godina
offline
Re: Mikrotik, povezivanje na captive portal s logi

Što znači loš speedtest? 1/1mbit? 5/5mbit? Budući je hotspot, ili je 100 ljudi gore zajedno s tobom, ili je ograničena brzina po korisniku. 

Dodatno, ako si u bridge, ip adrese dobivas od hotspota jel? 

Kupujem HUAWEI stickove za mobilni internet, ponude na PM ;)
3 mjeseca
offline
Re: Mikrotik, povezivanje na captive portal s logi

Brzina je smiješna, pola megabita.

Da, postoji ograničenje na tom hotspotu na 10 megabita po sekundi, (toliko dobijem kad se iz blizine spojim sa mobitelom.)




Poruka je uređivana zadnji put sri 4.8.2021 14:51 (Theophilus Ruy).
1
Nova poruka
E-mail:
Lozinka:
 
vrh stranice