AdGuard lokalna mreža

poruka: 1
|
čitano: 1.047
|
moderatori: Lazarus Long, pirat, XXX-Man, DrNasty, vincimus
1
+/- sve poruke
ravni prikaz
starije poruke gore
14 godina
offline
AdGuard lokalna mreža

Koristim AdGuard Home kao DNS server (port 53) i lokalni unbound server instaliran na istom uređaju kao upstream (port 5445). Do nedavno mi je sve uredno radilo. Uređaji u mreži šalju upit AGH-u preko porta 53 i on šalje upit unboundu. Bez obzira jesu li u pitanju upiti za lokalnu mrežu (domena.local) ili vanjski upit (npr bug.hr). AGH mi je i DHCP server. Preko jedne aplikacije sam uočio da mi za uređaje koji dobivaju IP od DHCP dodaje .lan TLD koji sam prije koristio i u AdGuardHome.yaml pronašao liniju i zamijenio domena.lan u domena.local (svugdje drugdje je uredno radilo i resolvalo .local). Od kada sam promijenio više mi ne resolva .local domene. 

 

Primjeri

 

1.

dig gateway.domena.local (mikrotik) mi na portu 53 (AGH) javlja da daje IP od DHCP iako je na unboundu namješteno da je static (10.0.0.X je static, 10.0.1.X je DHCP)

 

2. 

dig ws01.domena.local (desktop - IP je 10.0.0.10) na port 53 javlja idući odgovor, a razlika je i TTL koji je na unbound 300 a u odgovoru 10 (znači nije od unbound odgovor već od AGH)

ws01.domena.local.   10    IN    SOA   fake-for-negative-caching.adguard.com. hostmaster.ws01.domena.local. 100500 1800 900 604800 86400

 

3. 

dig ws01.domena.local -p 5335 (upit direktno šalje unboundu)

;; ANSWER SECTION:
ws01.domena.local. 300 IN A 10.0.0.10 

 

Odgovor 2 mi daje za večinu uređaja

 

Na upit dig -x na ip 10.0.0.10 (ws01) mi daje 

10.0.0.10.in-addr.arpa. 3600 IN PTR ws01.domena.local.

 

Što je zanimljivo ako idem resolvati npr ipad-od-mene.domena.local uredno ga prikaže, odnosno nema onog fake-for-negative-caching.adguard.com. već prikaže ono kako sam podesio SOA u unbound. Ping IP statičke uredno prolazi, dok domene ne. 

 

Dakle 2 problema su:

1. Ne resolva mi lokalnu domenu sa nazivom uređaja ako imaju statički IP (uređaj.domena.local)

2. Za gateway (Mikrotik) mi daje DHCP IP adresu iako ima statičku (dig -x 10.0.0.1 uredno prikaže gateway.domena.local)

 

Ima li tko ideja u čemu bi mogao biti problem?

 

Hvala 

https://www.plesnistudiovem.com | https://www.robertobilic.com/
Poruka je uređivana zadnji put pet 18.11.2022 12:40 (Robi).
Moj PC  
0 0 hvala 0
1
Nova poruka
E-mail:
Lozinka:
 
vrh stranice